Accès au VLAN MANAGEMENT a partir d'un autre VLAN DELL powerconnect 6224

Switchs et réseau

Switchs et réseau
Rejoignez les conversations dédiés aux switchs et réseaux Dell

Accès au VLAN MANAGEMENT a partir d'un autre VLAN DELL powerconnect 6224

Cette question a été répondue par DELL-Ghassane J

Bonjour a tous

Mon Problème DELL powerconnect 6224.

Je souhaiterai accéder au VLAN de management à partir d'un autre VLAN.

Le vlan de management est le vlan 100.

Mon pc est au vlan 60 et je souhaiterai me connecter en ssh ou http (192.168.100.1) pour administrer mon switch.

Merci de votre aide en ligne de commande

Pour info je suis stagiaire .

Réponse vérifiée
  • Bonjour,

    Sur ce modèle, le VLAN de management n'est pas routable.

    Par contre vous devriez pouvoir administrer le switch via tous les SVI (192.168.60.1, 192.168.200.1)
    (Vous pouvez appliquer des "management ACL" au besoin)

    Si cela ne vous conviens pas, vous pouvez aussi remettre le VLAN 1 (ou un autre) en tant que VLAN de management (sans IP) , et mettre une SVI sur le VLAN 100.
    Ce vlan sera alors routé.
    Par contre, certaines features utilisant le vlan de management pourraient ne pas fonctionner correctement (polling SNMP, authentication radius, etc...)

    Une autre solution consisterait à utiliser un autre routeur afin de router ce VLAN de management.

    Cordialement,

    Ghassane J

Toutes les réponses
  • Bonjour,

    Je ne peux pas trop m'avancer sans schéma réseau précis, mais voici une réponse "générale" :

    Afin de communiquer d'un VLAN à un autre il vous faudra un matériel de niveau 3, un routeur :
    62xx (1/gx - VLAN 100)  <-----> (1/gx - VLAN 10) Router (1/gx - VLAN 60) <-----> (PC)
    Sur le switch vous pouvez configurer l'utilisation de ce routeur en tant que gateway via la commande 'ip route default gateway'.

    Avez vous un routeur déjà en place et configuré afin de faire transiter le traffic d'un vlan à l'autre ?
    Arrivez vous à pinguer le router à partir du PC ? à partir du switch ?
    Est-ce fonctionnel en mettant un autre PC (dans le VLAN 100) à la place du switch ?
    Avez vous utilisé la commande tracert ou traceroute afin de suivre le flux et determiner le point bloquant ?

    Cordialement,

    Ghassane J

  • Merci pour votre response

    En gros j'ai un switch de niveau 3 et sur ce switch j'ai crée 3 vlans (vlan 100,60,200)

    J'ai choisit le vlan 100 comme vlan de management

    #ip address 192.168.100.100 255.255.255.0

    #ip address vlan 100

    #ip routing

    Voici mon running -config

    !Current Configuration:
    !System Description "PowerConnect 6224, 3.3.5.5, VxWorks 6.5"
    !System Software Version 3.3.5.5
    !Cut-through mode is configured as disabled
    !
    configure
    vlan database
    vlan 100,60,200
    vlan routing 50 1
    vlan routing 200 2
    exit
    hostname "sw1"
    stack
    member 1 1

    exit
    ip address 192.168.100.100 255.255.255.0
    ip address vlan 100

    ip https server

    ip routing

    interface vlan 60
    name "USERS"
    routing
    ip address 192.168.60.1 255.255.255.0
    exit
    interface vlan 200
    name "SERVER"
    routing
    ip address 192.168.200.1 255.255.255.0
    exit
    username "admin" password 30f9e50e9672649ff613447c14a78546 level 15 encrypted
    aaa authentication login "admin" line
    aaa authentication enable "admin" line
    line ssh
    login authentication admin
    enable authentication admin
    password 30f9e50e9672649ff613447c14a78546 encrypted
    exit


    ip ssh server
    !
    interface ethernet 1/g1
    switchport mode general
    switchport general pvid 100
    switchport general allowed vlan add 100
    switchport general allowed vlan remove 1
    exit
    !
    interface ethernet 1/g11
    switchport access vlan 60
    exit
    !
    interface ethernet 2/g1
    switchport mode general
    switchport general pvid 100
    switchport general allowed vlan add 100
    switchport general allowed vlan remove 1
    exit
    !
    interface ethernet 2/g19


    switchport access vlan 200
    exit
    exit

    Le but est de pouvoir connecter un pc sur le port 1/g11 avec un ip 192.168.60.X et d'acceder en http ou ssh au 192.168.100.100.

    Sachant que si je me connecte directement sur le port 1/g1 avec une ip 192.168.10.x ça marche.

    Le ping inter vlan marche (cad entre le vlan50 et le vlan200)

    Le vlan de management (vlan100 )n'est pas routable.

    Est ce que c'est possible ce que je veux faire?

    Merci encore J'espere que j'ai bien explique mon problème.

  • Bonjour,

    Sur ce modèle, le VLAN de management n'est pas routable.

    Par contre vous devriez pouvoir administrer le switch via tous les SVI (192.168.60.1, 192.168.200.1)
    (Vous pouvez appliquer des "management ACL" au besoin)

    Si cela ne vous conviens pas, vous pouvez aussi remettre le VLAN 1 (ou un autre) en tant que VLAN de management (sans IP) , et mettre une SVI sur le VLAN 100.
    Ce vlan sera alors routé.
    Par contre, certaines features utilisant le vlan de management pourraient ne pas fonctionner correctement (polling SNMP, authentication radius, etc...)

    Une autre solution consisterait à utiliser un autre routeur afin de router ce VLAN de management.

    Cordialement,

    Ghassane J

  • Bonjour,

    Avez-vous pu accéder à votre VLAN suite aux conseils de mon collaborateur ?

    Merci


    Eric