Problème d'authentification 802.1x de mon PC sur l'AD à travers un powerconnect 5548

Switchs et réseau

Switchs et réseau
Rejoignez les conversations dédiés aux switchs et réseaux Dell

Problème d'authentification 802.1x de mon PC sur l'AD à travers un powerconnect 5548

Cette question a été répondue par druartx

Bonjour,

J'ai configuré le NPS de Windows server 2008 R2 qui servira de serveur Radius et un switch Dell Powerconnect 5548 comme Radius Client. L'authentification de mon PC sur l'AD à travers le radius ne fonctionne pas. Il est à noté qu'avec la configuration du NPS actuelle sur un switch HP configuré en Radius Client, tiout fonctionne je n'ai donc pas de problème de serveur mais plutôt de config de switch.

Schéma du test

PC --> g5 5548P g24 --> f18 HP2530 f6 --> NPS

Est-ce que quelqu'un aurait une idée ?

voici la configuration de mon Dell:

USR-SW1# sh run
interface ethernet g1/0/5
spanning-tree portfast
exit
interface ethernet g1/0/5
switchport mode general
exit
dot1x system-auth-control
interface ethernet g1/0/5
dot1x re-authentication
exit
interface ethernet g1/0/5
dot1x port-control auto
exit
interface vlan 1
ip address 192.168.xxx.xxx 255.255.255.0
exit
hostname USR-SW1
radius-server host 192.168.xxx.xxxkey xxxxxx
aaa authentication dot1x default radius

Default settings:
Service tag: FNT9VS1

SW version 4.1.0.15 (date  20-Oct-2013 time  10:23:39)

Gigabit Ethernet Ports
=============================
no shutdown
speed 1000
duplex full
negotiation
flow-control on
mdix auto
no back-pressure

interface vlan 1
interface port-channel 1 - 32

spanning-tree
spanning-tree mode RSTP

Réponse vérifiée
  • bonjour,

    J'ai résolu mon problème.

    Maintenant, mon server NPS me remonte bien les connexions autorisée par l'AD.

Toutes les réponses
  • déjà fait et cela ne fonctionne pas. Le fait de configurer le port control en auto me désactive le service-acl input de l'interface.

    ci-joint la config

    int eth g15
    dot1x re-authentication
    dot1x mac-authentication mac-and-8021x
    dot1x port-control auto
    service-acl input Printers
    !
    mac-access-list Printers
    permit 00:00:aa:c3:b8:6c 00:00:00:00:00:00 any
    deny any any

    USR-SW1#sh dot eth g15

    802.1x is enabled

             Admin              Oper          Reauth   Reauth     Username
    Port     Mode               Mode          Control  Period
    -------- ------------------ ------------- -------- ---------- -----------------
    g15      Auto               Unauthorized  Enabled  3600       n/a

    Quiet period:            60 Seconds
    Tx period:               30 Seconds
    Max req:                 2
    Supplicant timeout:      30 Seconds
    Server timeout:          30 Seconds
    Session Time (HH:MM:SS): 00:00:00
    MAC Address:<<<<<<<<<<<<<<<<<<<<<<<<< je ne vois pas mon imprimante de l'ACL
    Authentication Method:   Remote
    Termination Cause:       Reauthentication failed

    Authenticator State Machine
    State:                   CONNECTING

    Backend State Machine
    State:                   IDLE
    Authentication success:  0
    Authentication fails:    0

  • quelqu'un pourrait-il me dire comment trouver le password pour passer en mode debug ?