Dell PowerEdge R430 (09/2016 - BIOS v2.0.1) : plantage avec un OS Linux ayant un noyau 4.x (dès le démarrage du système de fichier initial).

Serveurs PowerEdge - Matériel

Serveurs PowerEdge  - Matériel
Rejoignez les conversations sur les serveurs PowerEdge et les logiciels de management systèmes.

Dell PowerEdge R430 (09/2016 - BIOS v2.0.1) : plantage avec un OS Linux ayant un noyau 4.x (dès le démarrage du système de fichier initial).

Cette question a suggéré des réponses

Bonjour,


Suite à l'achat de 2x serveurs Power Edge R430 (achat en septembre 2016 - BIOS v2.0.1 puis mise-à-jour en v2.3.4), je tente d'installer un système Linux ayant un noyau 4.x (SUSE Linux ES 12 SP2, Debian Stretch & Ubuntu 16.04 LTS) sans succès sur les 2 PE R430.

Pour résumé la situation, le lancement/execution du noyau 4.x plante très tôt (environ 1 seconde après le lancement du système de fichier initial - linux/initramfs).
Très peu d'information s'affiche à l'écran. Aucun erreur n’apparaît.

La seule option passée au noyau "acpi=off" (désactivation de l'interface avancée de configuration et de gestion de l’énergie) permet de booter/démarrer sans plantage, mais ne permet pas l'utilisation du serveur correctement (seul 1 coeur apparait !!!!)


Comme précisé en préembule, j'ai pris le temps d’effectuer plusieurs tests avec divers systèmes Linux ayant un noyau 4.x.
Tous plante à l'identique : SUSE Linux ES 12 SP2 avec le noyau 4.4, Ubuntu avec les noyau 4.2, 4.4 et 4.8, ainsi que Debian avec le noyau 4.9.



Pour information :
J'ai tester de passer en mode HBA (par le Bios -> Carte RAID -> Controller Management -> Advanced Controller Management -> Switch to HBA mode -> REBOOT), malheureusement, cela ne change rien et cela plante toujours à l'identique.

J'ai 2x autres serveurs PE R430 plus anciens (achat octobre 2015 - BIOS v1.2.6) et je n'ai eu aucun problème a installer/démarrer sur un OS Linux ayant le noyau v4.4.

Par contre les systèmes ayant un noyaux 3.x (v3.0 sous SUSE Linux ES 11 SP4, v3.12 sous SUSE Linux ES 12 SP1, v3.13 sous Ubuntu et v3.16 sous Debian) fonctionne sans aucun souci !!!



Résumé concernant l'OS SUSE Linux ES :
- la version SUSE Linux ES 12 SP2 (kernel : 4.4.21) ne fonctionne pas !!!
- la version SUSE Linux ES 11 SP4 (kernel : 3.0.101) fonctionne,
- la version SUSE Linux ES 12 SP1 (kernel : 3.12.49) fonctionne,

Je n'ai, pour l'instant, pas pu faire un test avec l'OS SUSE Linux Enterprise Server 11 SP3 (datant de juillet 2013) étant donné que je ne trouve pas cette version dans les téléchargements du site de SUSE.


Avez-vous eu écho de cette problématique (Dell PowerEdge R430 & Linux kernel 4.x) ?

-

M. FARGET Vincent.

Toutes les réponses
  • Bonjour,

    pourriez vous m'envoyer en privé le service tag du R430?

    Merci
    Stéphane

  • Bonjour,

    voici la liste non exhaustive des OS Linux supportés pour votre serveur :

    • Red Hat® Enterprise Linux® (RHEL)7.0
    • RHEL 6.5
    • SUSE™ Enterprise Linux Server (SLES) 12
    • SLES 11 SP3
    • Ubuntu® (Support and qualification by third party Canonical)

    Je vous invite donc à mettre à jour votre OS driver pack et passer par le lifecycle pour préparer votre installation.

    Pour plus d'information :

    Cordialement,
    Stéphane

  • Bonjour,

    L'OS driver pack est inclus dans le lifecycle controller de votre serveur. Cela permet de fournir les bons drivers lors de l'installation du système d'exploitation

    voici la dernière version pour votre serveur

    cordialement,
    Stéphane

  • Bonjour,


    Comme vous me l'avez conseillé, je viens de mettre à jour, par le "Lifecycle Controller" -> "Mise à jour de la micrologiciels", le composant "Dell OS Driver Pack, 16.04.07, A00" (Version : 16.04.07) grâce au fichier "Drivers-for-OS-Deployment_Application_MRW6J_WN64_16.10.10_A00.EXE".

    La version du composant "Dell OS Driver Pack" affiche maintenant : "16.10.10".


    Pour l'installation de l'OS Linux (SUSE Linux ES 12 SP2 ou Ubuntu Xenial 16.04 LTS Server), en passant par le "Lifecycle Controller" -> "Déploiement du SE", je ne les vois pas apparaître dans la liste déroulante des "Systèmes d'exploitation disponibles".
    (La sélection de "SuSE Entreprise Linux 12 SP1 x64" mentionne que le media ne correspond pas).
    J'ai donc choisis "Any Other Operating System" pour tenter d'installer l'OS Linux.

    Malheureusement l'installation se bloque (plantage - redémarrage physique obligatoire) toujours au moment de l'execution du fichier disque image initial (noyau) comme les tentatives d'installation précédentes.
    capture d'écran :

    Précision : seul le paramètre "acpi=off" passé au noyau permet le démarrage sans plantage.

    Avez-vous une idée sur l'origine du problème ?
    Faut-il mettre à jour tous les composants (comme pour le "Dell OS Driver Pack") ?

    (j'ai aussi mis à jour le composant "OS COLLECTOR" via le Lifecycle Controller)



    Bien cordialement.
    -
    M. FARGET Vincent.

  • Bonjour,

    Avez-vous essayé avec la version SUSE Linux Enterprise Server 12 SP1

    https://www.suse.com/products/server/download/

    Cordialement,
    Stéphane

  • Bonjour,

    Oui : cf. mon tout premier message de cet article.

    Comme mentionné, la version SUSE Linux Enterprise Server 12 SP1 fonctionne, tout comme l'OS Linux Ubuntu Trusty v14.0, toutes deux ayant par défaut des noyaux linux v3.x.

    Bien cordialement.

    -

    M. FARGET Vincent.

  • Bonjour,

    Avez-vous une idée d’où peut provenir mon souci d'installation ?

    Bien cordialement.

    -

    M. FARGET Vincent.

  • Bonjour,

    Avez-vous essayé les deux modes de BOOT UEFI et legacy bios sur ce serveur lors de l'installation?

    Cordialement,
    Stéphane

  • Bonjour,

    Oui, bien sûr. J'ai bien essayé les deux modes de boot pour l'installation : Legacy et UEFI.

    Malheureusement cela ne change rien !!!

    Bien cordialement.

    -

    M. FARGET Vincent.