SAN QLOGIC QME2472 : Mise à jour firmware - problème patch QLE2462 FC HBA,QLE2460, 02.22.03, 7.0.0.20

Serveurs PowerEdge - Matériel

Serveurs PowerEdge  - Matériel
Rejoignez les conversations sur les serveurs PowerEdge et les logiciels de management systèmes.

SAN QLOGIC QME2472 : Mise à jour firmware - problème patch QLE2462 FC HBA,QLE2460, 02.22.03, 7.0.0.20

Cette question a été répondue par Dell-Stephane T

Bonjour,

  Ne pouvant enrichir le ticket "SAN QLOGIC QME2472 : Mise à jour firmware" du 15 juin traité par Dell-Stephane T, je me permets d'en ouvrir un nouveau.

  Le patch de la version 7.0.0 du firmware ne semble pas convenir :

Dell Update Package 14.05.00 (BLD_156)

Copyright (c) 2014 Dell, Inc. All Rights Reserved.

Release Title:

QLE2462 FC HBA,QLE2460, 02.22.03, 7.0.0.20

 

Release Date:

June 12, 2014

 

Default Log File Name:

3D0P17.0.0.20

 

Reboot Required:

Yes

 

Description:

Dell Qlogic Firmware DUP for QLE2460 and QLE2462 adapters.

 

Release notes "release_isp24xx-25xx-81xx-83xx_firmware_70200_revB_7.0.0.8.txt" for Dell 7.0.0.8 (2.20.09) DUP package

document the changes and fixes present in Qlogic ISP 24xx/25xx/81xx/83xx Qlogic firmware versions release 7.20.00

and earlier.

 

Supported Device(s):

QLE2462 FC HBA

 

QLE2460

 

Important Device Information:

* Do not run other applications while executing Dell Update Packages.

Page notes with 'less', press 'q' to continue DUP exec; lines 1-28/28 (END)

 

 

Collecting inventory...

...........

Running validation...

 

This Update Package is not compatible with your system configuration.

 

[root@cg35_b3 qlogic]#

 

 

[root@cg35_b3 qlogic]# cat /proc/scsi/qla2xxx/1

QLogic PCI to Fibre Channel Host Adapter for QME2472:

        Firmware version 4.04.09 Paradise [84XX] , Driver version 8.02.09.02.04.08-d

ISP: ISP2432

Réponse vérifiée
  • Bonjour,

    Pourriez-vous me communiquer en privé le services tag des serveurs concernés.

    Cordialement,
    Stéphane

Toutes les réponses
  • Peut-être faut-il lancer le batch avec l'option "-n" pour enlever des vérification ?

    Cela me parait risqué mais je suis sur du type de mes cartes (QME2472) :

    aide en ligne sur le patch :

    Command-line options for the Update Package

    Usage: <package name> [options...]

    Options:

    -h,--help     : Display command-line usage help
    -c            : Determine if the update can be applied to the system (1)
    -f            : Force a downgrade to an older version. (1)(2)
    -q            : Execute the update package silently without user intervention
    -n            : Execute the update package without security verification
    -r            : Reboot if necessary after the update (2)
    -v,--version  : Display version information
    --list        : Display contents of package (3)
    --extract <path> : Extract files to specified path (3)(4)

    (1) Can NOT use -f with the -c option
    (2) Only takes effect if used with -q
    (3) Can be used only before extracting the package
    (4) Can NOT use --extract with any other option

  • Bonjour,

    navré pour la réponse tardive, pourriez vous essayer d'installer la version plus récente ci-dessous :

    Version

    Version 02.22.03, 7.0.0.20

    Category

    Fibre Channel

    Release date

    11 Mar 2015
    Applies to
    QLE2460
    QLE2460 LP
    QLE2462 FC HBA
    QLE2462 FC HBA LP
    QLogic Family of Server Adapters Drivers
    Si le problème de mise à jour persiste, il faudra peut être installer des versions intermédiaires en consultant les release notes.
    Pourriez-vous m'indiquer la version actuelle de votre firmware ?
    Cordialement,
    Stéphane
  • Bonjour Stéphane,

    Voici les versions de firmware et driver :

    [root@cg35_b3 qlogic]# cat /proc/scsi/qla2xxx/1
    QLogic PCI to Fibre Channel Host Adapter for QME2472:
            Firmware version 4.04.09 Paradise [84XX] , Driver version 8.02.09.02.04.08-d

    ATTENTION il s'agit de carte fille pour blade M600 - le modèle est QME2472

    Il ne s'agit pas de carte QME2462 (pour des serveurs rack ?) 

       Le fichier de la V7 semble corrompu, même après plusieurs téléchargements :

    Fibre-Channel_Firmware_3D0P1_LN_02.22.03_7.0.0.20.BIN

    J'obtiens le message" ci dessous :

    zcat: /tmp/.dellSez-Fibre-Channel_Firmware_3D0P1_LN_02.22.03_7.0.0.20.BIN42869.SH1027: invalid compressed data--format violated

    La signature ne semble pas bonne :
    gpg: Impossible de v▒rifier la signature: cl▒ publique non trouv▒e

    Je fais la même opération avec la V8 (Fibre-Channel_Firmware_8G1G7_LN_02.22.09_8.0.0.11.BIN) pas de problème de transfert mais j'ai le message ci-dessous :

    This Update Package is not compatible with your system configuration.

  • Bonjour,

    Pourriez-vous me communiquer en privé le services tag des serveurs concernés.

    Cordialement,
    Stéphane